Wiki | Community | Discussion Forum | Q&A

Error starting exercise

Hi!
I’m having problems starting the cat and mouse exercise … I followed the instructions in INSTALLATION INSTRUCTIONS - Robotics-Academy to install jdrobot, but when I try to start the exercise I get the following error.


I have tried other exercises and can open them without problem …

Hi,

This error is caused because you have not installed the xmlstarlet tool in your system. If you are using Ubuntu, you can install this tool in Ubuntu via apt:

sudo apt install xmlstarlet

This requirement is not included in the installation guide, so maybe it should be added to avoid future issues.