Wiki | Community | Discussion Forum | Q&A

Execution Error

Hi, I’m having a few problems executing the exercise that I don’t know how to solve.
There are the execution log errors.

[mouse/rqt_gui-9] process has died [pid 2640, exit code -11, cmd /opt/ros/melodic/lib/rqt_gui/rqt_gui --perspective-file /opt/ros/melodic/share/jderobot_assets/perspectives/drone_teleop.perspective __name:=rqt_gui __log:=/home/roberto/.ros/log/2e7b97ec-7f2a-11ea-8fc8-484520d13bb6/mouse-rqt_gui-9.log]. log file: /home/roberto/.ros/log/2e7b97ec-7f2a-11ea-8fc8-484520d13bb6/mouse-rqt_gui-9*.log

[cat/rqt_gui-4] process has died [pid 2424, exit code -11, cmd /opt/ros/melodic/lib/rqt_gui/rqt_gui --perspective-file /opt/ros/melodic/share/jderobot_assets/perspectives/drone_teleop.perspective __name:=rqt_gui __log:=/home/roberto/.ros/log/2e7b97ec-7f2a-11ea-8fc8-484520d13bb6/cat-rqt_gui-4.log]. log file: /home/roberto/.ros/log/2e7b97ec-7f2a-11ea-8fc8-484520d13bb6/cat-rqt_gui-4*.log

And the .log files:

  • acat-rqt_gui-4.log
    [rospy.client][INFO] 2020-04-15 17:03:16,320: init_node, name[/cat/rqt_gui], pid[2424] [xmlrpc][INFO] 2020-04-15 17:03:16,321: XML-RPC server binding to 0.0.0.0:0 [xmlrpc][INFO] 2020-04-15 17:03:16,321: Started XML-RPC server [http://roberto-GL552VW:38041/] [rospy.init][INFO] 2020-04-15 17:03:16,321: ROS Slave URI: [http://roberto-GL552VW:38041/] [rospy.impl.masterslave][INFO] 2020-04-15 17:03:16,321: _ready: http://roberto-GL552VW:38041/ [rospy.registration][INFO] 2020-04-15 17:03:16,321: Registering with master node http://localhost:11311 [xmlrpc][INFO] 2020-04-15 17:03:16,321: xml rpc node: starting XML-RPC server [rospy.init][INFO] 2020-04-15 17:03:16,421: registered with master [rospy.rosout][INFO] 2020-04-15 17:03:16,422: initializing /rosout core topic [rospy.rosout][INFO] 2020-04-15 17:03:16,425: connected to core topic /rosout [rospy.simtime][INFO] 2020-04-15 17:03:16,427: initializing /clock core topic [rospy.simtime][INFO] 2020-04-15 17:03:16,432: connected to core topic /clock

  • acat-rqt_gui-9.log
    [rospy.client][INFO] 2020-04-15 17:03:25,262: init_node, name[/mouse/rqt_gui], pid[2640] [xmlrpc][INFO] 2020-04-15 17:03:25,262: XML-RPC server binding to 0.0.0.0:0 [xmlrpc][INFO] 2020-04-15 17:03:25,263: Started XML-RPC server [http://roberto-GL552VW:32865/] [rospy.init][INFO] 2020-04-15 17:03:25,263: ROS Slave URI: [http://roberto-GL552VW:32865/] [rospy.impl.masterslave][INFO] 2020-04-15 17:03:25,263: _ready: http://roberto-GL552VW:32865/ [rospy.registration][INFO] 2020-04-15 17:03:25,263: Registering with master node http://localhost:11311 [xmlrpc][INFO] 2020-04-15 17:03:25,264: xml rpc node: starting XML-RPC server [rospy.init][INFO] 2020-04-15 17:03:25,364: registered with master [rospy.rosout][INFO] 2020-04-15 17:03:25,365: initializing /rosout core topic [rospy.rosout][INFO] 2020-04-15 17:03:25,370: connected to core topic /rosout [rospy.simtime][INFO] 2020-04-15 17:03:25,372: initializing /clock core topic [rospy.simtime][INFO] 2020-04-15 17:03:25,380: connected to core topic /clock

It seems the same error to me, but i don´t know what to do. I tried to install it in my old linux distribution, in a new distribution and in a virtual machine (all in Ubuntu 18.4) and I always have the same result, so I think i’m forgetting to install something…

I followed the steps of the webs: http://jderobot.github.io/RoboticsAcademy/installation/ and http://jderobot.github.io/RoboticsAcademy/exercises/Drones/drone_cat_mouse.

Thanks for the help.

Hi @r.gallardoc,

Try to install xmlstartlet:

 sudo apt-get install -y xmlstarlet

Let me know if that solves your problem.

Pedro.

Hi, I already have xmlstarlet installed but just in case i have reinstalled it. Unfortunately the error remains.

Thanks

Hi @r.gallardoc ,

Could you please add more information about your error?

Hi, I know that the dead processses are the GUIs controls of the cat and the mouse. If you want I can add the full log of the roslaunch, but I think that I already added the interesting lines in the main post.

Thank you again for your time

I have exactly the same error, same logs. Any solutions? @r.gallardoc @pariasp

Thanks

It would be great if you add the full log and the execution error at the command line.

Hi @nygage, we are working on it. As soon as we detect the bug you’ll be notified.

Pedro.

Hi,there are the complete logs, due to the limit of words in the forum I put a link for the logs download.

Thank you.

Hi @r.gallardoc and @nygage

This segmentation fault error probably has to be with some incompatibilities between the QT libraries and the OpenCV version you have installed in your system.

Have you used sudo pip install opencv-python? If so, you have installed OpenCV 4.2, which at present is causing some QT-related issues when launching our RQT drone_teleop

Try uninstallin OpenCV via sudo pip uninstall opencv-python and install version 3.2 using sudo apt-get install libopencv-dev python-opencv. Let us know if that works.

Best,
Diego.

Yes, it worked for me, thanks!

It worked for me too, thak you so much! :slight_smile: