Formula 1 Example

Welcome!. This is where the comments on the Formula1 API example are shared


I’m trying to launch the “f1.launch” world following the instructions shown on exercise “follow_line”, but f1 model or scenario are not loaded. I’ve tried to launch another world, but the same basic scene appears (see attached picture). So, probably, it is my fault, but I don’t know why I’m wrong.

Could anyone help me? Thanks in advance,


Hi Julio!

a couple of questions to trace the problem:

  1. How did you install JdeRobot? via debian packages? or manual compiling it?
  2. Can you show the log of gazebo? You have to edit the f1.launch file and change the flag verbose from False to True and paste here the output of the terminal when you launch the exercise.

You can try the following to see if this helps tho:

source /opt/ros/kinetic/setup.bash
source /opt/jderobot/setup.bash
source /opt/jderobot/share/jderobot/gazebo/
source /opt/jderobot/share/jderobot/gazebo/

on a terminal and launch the example in the same terminal you sourced those files.

Hope it helps!

Thank you so much, Fran, and sorry for the delay to reply.
I followed your instructions (copy/paste the “source” lines) and it worked fine.

Thanks again,