Wiki | Community | Discussion Forum | Q&A

Installation error

Hi! All times I try to install catkin build I have the same issues and problems with this

Anyone could help me? I have deleted all the files and reinstall them more than 10 times. I don’t know what happens. In the second error, he says it’s from the compiler. An internal compiler error. if anyone could help me I will be very grateful.

Hi @rufinogs,

Have you checked if all the dependencies are met? You can check it with:

rosdep update
rosdep check --from-paths . --ignore-src --rosdistro melodic

Pedro.

Hi @pariasp , they are all updated and checked

Hi again,

Can you give me further information of your system? Which Ubuntu and Python version are you using?

Hi @pariasp, I am using ubuntu 18.04 this ubuntu is in a VM called parallels and python is in 2.7.17

Hi again @rufinogs,

Try to install this:

pip3 install --user packaging

Source: https://discuss.px4.io/t/generating-uorb-topic-headers-failed/16016

I installed to try to solve the first issue of the logs and nothing happends they are the same issue nothing change.

Try to update your python version to 3.X. After that, install packaging again and rebuild catkin_src.

Perfect I will try. thanks for all Pedro @pariasp

I update to the lastest version of python and reinstalled all and continues with the same issue… :pensive: :man_facepalming:

Hi @rufinogs,

Can you post the logs that you are getting?

Also try to add this alias at the top of your .bashrc, just to discard it’s not a problem between python versions.

alias python=python3

Pedro.