Remote urjc 2 doesnt import well

For some reason it doesnt recognice the functiones of ompl and opencv

image

Tanks!

It doesnt work in local either

Hi, a new RADI 4.4.30 has been published solving this issue. The remote URJC 2 will be updated in about an hour. If this error persists, please let us know and attach or send through a private message the complete code.

Hi, I am still running into the same error, im on windows by the way

Hi, are you using the latest RADI 4.4.30? The RADI in use can be seen at the top of the website on the Robotics Backend box. If that is the case, please send us your code or the lines of your code that reports the E1101 error

def __init__(self, image):
    space = ob.RealVectorStateSpace()
    self.image_ = image
    height, width, channels = self.image_.shape
    space.addDimension(0.0, width)
    space.addDimension(0.0, height)
    self.maxWidth_ = width
    self.maxHeight_ = height
    self.ss_ = og.SimpleSetup(space)

    # get state validity checking for this space
    self.ss_.setStateValidityChecker(ob.StateValidityCheckerFn(Plane2DEnvironment.isStateValid))
    space.setup()


  def plan(self, start_row, start_col, goal_row, goal_col):
    if not self.ss_:
        return False
    start = ob.State(self.ss_.getStateSpace())
    start()[0] = start_row
    start()[1] = start_col
    goal = ob.State(self.ss_.getStateSpace())
    goal()[0] = goal_row
    goal()[1] = goal_col
    self.ss_.setStartAndGoalStates(start, goal)
    # generate a few solutions; all will be added to the goal
    for _ in range(10):
        if self.ss_.getPlanner():
            self.ss_.getPlanner().clear()
        self.ss_.solve()
    ns = self.ss_.getProblemDefinition().getSolutionCount()
    print("Found %d solutions" % ns)
    if self.ss_.haveSolutionPath():
      self.ss_.simplifySolution()
      p = self.ss_.getSolutionPath()
      ps = og.PathSimplifier(self.ss_.getSpaceInformation())
      ps.simplifyMax(p)
      ps.smoothBSpline(p)
      return True
    return False


It seems now that cv2 is not causing problems

Hi, we have just published a new RADI 4.4.31 regarding this issue. Please let us know if the problem is solved. The Remote URJC 2 farm will be updated in about an hour, sorry for the delay.

it works using new RADI